Jump to content


< Back to Forum


 

Hmp Ip Media Server No Voice Response.


  • Please log in to reply

#1 SupportTeam 02 January 2018 - 07:21 PM

Customer wrote:

 

We are using Windows server 2012 64bit operating system with Bria xlite softphone.

Please note we have not yet registered with sip service provider because it is still in the testing mode.

1.server 2012 IVR setup done which is located @ datacenter.

2.softphone is setup on my local machine windows 10 which is connected to public ip.

3.when I dial the with softphone can see this message on server side:-  IP Media server no voice response.

4. server 2012 operating system does not have sound card drivers setup is it ok ? OR IVR Needs sound card ?

  • ipmediaserver_error.jpg


#2 SupportTeam 02 January 2018 - 07:27 PM

Does this server have multiple network interfaces?

 

If yes then please stop the Dialogic HMP service (using DCM), select the card, go to Config -> Default IP, and select the 'first' IP interface. Then start the Dialogic HMP service again (using DCM) and try running the IP Media Server test again.



#3 satishkumar1066 02 January 2018 - 08:56 PM

Hi,

 

yes this server have multiple network interfaces.

 

stoped the dialogic hmp service done in the Config ->Default first interface ip is set and started DCM Service.

on server running with IP Media Server for test yes i can see the screen playing MAIN_MENU State but no sound able to hear on my softphone Bria Xlite  can you guide.

screenshot listed below of the server running play and when I cut the call from softphone can see second screenshot.

 

 

 

  • ipmediaserver menu play.PNG
  • ipmediaserver menu play-stoped.PNG


#4 satishkumar1066 02 January 2018 - 09:06 PM

Hi,
 
yes the server is having multiple nic cards and set to :- 'first' IP interface now when I dial thought it is playing IP Media server demo but still unable to listen demo sound screenshot attached.
  • ipmediaserver menu play.PNG
  • ipmediaserver menu play-stoped.PNG


#5 SupportTeam 02 January 2018 - 09:13 PM

Can you please do a WireShark capture of the SIP and RTP traffic.

 

Are you perhaps able to run the WireShark capture on both systems? ie. both the Win2012 server and Win10 soft-phone machine?

When we have both captures we can the see what packets are are seen at both ends.

 

Could it be some firewall issue?

 

You need to open ports 49100 and above (to say 50000) on both systems to allow RTP traffic (the sound data). see: http://www.voiceguid...dialogichmp.htm

 

Are you able to temporarily just disable the firewalls on both systems and do a test call?

 

When doing a WireShark capture you can use this in the Display Filter Expression text box (at top of WireShark):

 

sip || rtp

 

To save WireShark trace use the File->Export Specified Packets and make sure the 'Displayed' option is selected.



#6 satishkumar1066 05 January 2018 - 09:18 PM

Hi,

 

WireShark capture is done

though i run wireshark capture on both sides on server 2012 and windows 10 machine with softphone only on Server 2012 i can able to capture the packets but on my windows 10 machine nothing i can capture on sip it is empty.

no idea it might be firewall issue ?

As you said will try opening ports on both sides 49100 and above (to say 50000) about machines firewall is switched off on both sides no idea on public ip.

 

please check the wireshark captured file which is attached this is from server side only.

 

can you suggest what exactly i should follow to get sound hear on my softphone.

 

the attachment was missing..resent

 

Thanks

Satish  Kumar K

 



#7 SupportTeam 05 January 2018 - 09:44 PM

Attached WireShark trace was done on the VoiceGuide machine, right? (Win2012, 10.1.1.5).

 

Attached trace shows that 10.1.1.5 is sending RTP to caller (183.82.98.134), but 183.82.98.134 is not sending any RTP to 10.1.1.5 

(also the RTP sent is just silence...)

 

Did you do the WireShark trace on the 183.82.98.134 machine? What did that show? Can you post it here?

 

Can you try using MicroSIP softphonefor testing instead ( https://www.microsip.org/ )

 

Also, can you, for initial testing, have the softphone machine on the same network (ie, on  10.1.1.X network)? It looks like right now you are most likely having some firewall issues that prevent RTP from 183.82.98.134 reaching 10.1.1.5

 

Is 10.1.1.5 a separate physical machine, or a VM? If a VM then what VM is it running on?



#8 satishkumar1066 05 January 2018 - 10:37 PM

hi

 

yes it is traced on voiceguide server 2012 10.1.1.5

 

it is 10.1.1.5 is sending RTP to 183.82.98.134 it means this public ip needs to allow ports on firewall right (183.82.98.134) right ?

 

yes it did wire shark on 183.82.98.134 machine it is not showing any thing as i already mentioned in my previous post (empty).

 

so firewall is prevent RTP from 183.82.98.134 reaching 10.1.1.5 

coming to point of initial testing 10.1.1.5 is located @ datacenter which is completely on different location uk and mine 183.82.98.134 is from india so i cannot test them on same network.

 

10.1.1.5 is dedicated box it is not VM

 

coming to my internal network 183.82.98.134 before i install this on server i was running two machines on my personal lan one is windows 10 machine and other one is virtual VM this two are working perfectly without any issue voice commuction and sip call flow is working fine becuz they are behind the firewall which is location on my internal lan.

 

give me some time i will come back need to allow ports on firewall 49100 and above (to say 50000) which is pending @ my end.

 

you also mentioned to test the MicroSIP softphone right i did this on my pcs where IVR was running perfectly but no voice can be listen this is behind the firewall

which is like 192.168.2.4 (PC) from to voiceguide server 192.168.2.63 (VM).



#9 SupportTeam 05 January 2018 - 10:49 PM

Trace on 183.82.98.134 should show the SIP packets, as we see those are exchanged. Does 183.82.98.134 trace show SIP ?

 

Does 183.82.98.134 trace show RTP being sent out?

 

If its not showing either of the the above then does the 183.82.98.134 machine have multiple network interfaces? Perhaps the WireShark tracing was done on wrong interface?



#10 SupportTeam 06 January 2018 - 03:27 PM

Instead of trying to test this system with soft-phone from another country, it may be just faster to connect this VoiceGuide server to the lines that it will be using.

 

Do you have connection details of the switch/service that will be used to route calls to this system? Will you have a direct IP routes SIP trunk, or will you need to SIP REGISTER the system with the switch/service ?