Jump to content


< Back to Forum


 

Windows 10


  • Please log in to reply

#1 benjamin 13 August 2015 - 12:03 AM

Will Voice Guide run on Windows 10? Has this been tested?

 

Thank you



#2 SupportTeam 13 August 2015 - 02:34 PM

We tried it and it works fine on Windows 10.

 

Only glitch that we had is that at startup time the 'Icon Tray Monitor' app did not start.The app was installed and was visible in the Windows' Task Manager's 'Startup' list of apps to start, but it just was not started. So it needed to be started manually.

 

But the VoiceGuide service itself starts when Windows 10 is restarted, and it works fine.

 

Please note that Dialogic drivers are not yet listed as supporting Win10.



#3 benjamin 29 August 2015 - 08:49 AM

Thank you, good to know!



#4 ApexData 10 December 2015 - 04:59 AM

I am in the process of setting up a new VG7 system.

I would like to go with Windows 10 but am concerned about Dialogic not showing supported drivers for Windows 10.

Since the original post was in August, any idea when those might be available ?

Are we saying the current drivers work fine on Windows 10 they just don't have the Dialogic seal of approval ?



#5 SupportTeam 10 December 2015 - 05:47 AM

Dialogic has not yet released a version of drivers that supported Windows 10.

 

Current Dialogic drivers do not seem to work on Windows 10. We tried them when Windows 10 first came out and they did not work.



#6 ApexData 18 October 2016 - 01:32 AM

Inquiring again about Windows 10.  I see that the 'current' dialogic drivers for download on your site include Windows 10 in the description.  However, the download file appears to be the same download file that was available back in December 2015.  Last post from Support in December 2015 indicated the dialogic drivers did NOT work on Windows 10.  What is the current status of voice guide and dialogic drivers for Windows 10 ??



#7 SupportTeam 18 October 2016 - 05:49 AM

Recent advice from Dialogic advises that Win10 is now supported, with a couple of notes::

DoDocument Rev 107 - published July 7, 2016
Additional Updates for Service Update 271.

Service Update 271 adds support for Windows 10 and Windows 8.1 Operating Systems
for the full Dialogic JCT Media Board family.  

Notes:

1. Power Management is not supported and must be disabled.

• Failure to disable Power Management could cause the system to crash (Blue
Screen) upon resuming from Sleep or Hibernation states.
• As part of Power Management, what is known as "Hybrid Shutdown" or "Fast
Boot" is also not supported and must be disabled.

2. Currently supported Dialogic boards operate in Windows 10 with no specific
configuration changes

Link to Dialogic's document: https://www.dialogic...ease_update.pdf

 

We have ran current versions of VoiceGuide and Dialogic drivers with Windows' Power Management disabled and have not encountered any issues, and have had no issues reported to us for clients who we know are currently using Win10.



#8 ApexData 03 December 2016 - 12:49 AM

Attempting to put together our first Windows 10 VG platform and running into a number of issues.

Using the latest VG software and drivers with Dialogic D4PCIUFEQ voice cards.

Cannot get the TTS to function.

Trying to use the built-in SAPI 'Microsoft Zira Desktop'.

Not sure the VG.INI is configured properly..from the original install the VG.INI does not have a [TTS] section.

I saw on a previous post that may be required but we have never added that section in other working Windows 7 VG7 platforms so I attempted to put that section in.

 

When I call the unit, it first speaks the 'Welcome.wav' file with no problems.

Next, it is supposed to do a TTS for the file 'Enter_MbrNbr.txt' but that does not occur.

I then get a message 'sound file is not found'. 

I have attached the VG.INI (as vgini.txt), 1201_ktTts.txt and 1201_1024_vgengine.txt.

Thanks for any help in diagnosis. 



#9 SupportTeam 03 December 2016 - 09:12 AM

Could you please test TTS operation on this system by using a "Play" type module to play:

 

- a text specified in the module

 

- a .txt file specified as the file to be played.

 

Please post traces of those two TTS attempts. (vgEngine and vgTts traces)



#10 ApexData 07 December 2016 - 01:29 AM

I created a 'test.vgs' to run on line 1 with 'play' of a wav, .txt file and a text string.

Our 'normal' script set to run on line 2.

When I call line 1, it seems to work fine.  Speaks the wav, .txt file and the text string.

When I call line 2, does not work.  Speaks 'voice file cannot be found'...twice.

 



#11 SupportTeam 07 December 2016 - 05:08 PM

The script on first line uses "Play" type modules to play out a .txt file using TTS.

 

The script on second line uses "Get Number" type modules to play out a .txt file using TTS.

 

So looks like there is a bug right now in "Get Number" type modules playing .txt file using TTS.

 

We willl ook into this and should be able to provide a resolution in a few days.

 

In meantime, as a workaround, are you able to use static .wav files in these "Get Number" type modules instead?

If the files do contain a dynamic component that changes from call to call then are you able to use a "Play" type module to speak that dynamic component out first, and then use a static.wav file in the "Get Number" type module?

 

Files generated by TTS are saved in C:\Program Files (x86)\VoiceGuide\temp\ directory, so you can generate the static .wav files by running a scritpt that speaks the required text using Play modules, and then just copy those files to your own location.



#12 ApexData 07 December 2016 - 11:30 PM

While changing everything to .wav files could possibly be done, this is a rather large application and would rather leave 'as is'.

I will await your update for the fix.

Thanks



#13 SupportTeam 09 December 2016 - 08:35 AM

Please update your system to this version of VoiceGuide:

 

http://www.voiceguid...161209_KZEP.exe

 

The above version of VoiceGuide should fix the TTS play in "Get Number" type modules bug which you encountered.

 

Please post traces as before if you still encounter any issues.


To change from one release of VoiceGuide v7 to another:

1. Stop VoiceGuide Service and exit all VoiceGuide programs. (eg Script Designer, Tray Icon Service Monitor, etc) and all other programs.

2. Run the VoiceGuide install and install into same directory as existing installation. (Do NOT uninstall the previous VoiceGuide installation).

3. Start  VoiceGuide service.


Running the VoiceGuide install program over the top of an existing VoiceGuide installation will NOT overwrite existing configuration or license files (Config.xml, ConfigLine.xml, VG.INI, VmBoxList.xml, etc) and will NOT remove any of users script or sound files, and will NOT remove any log files etc



#14 SupportTeam 14 December 2016 - 06:09 PM

Just as a general comment about using TTS for static sound files (sound files that do not change from call to call) :

 

If using TTS there is a slight delay before the sound starts to actually play.

This delay is due to TTS engine delays before it starts to generate the sound. It is usually between 100ms - 200ms (0.1 - 0.2 second). It varies depending on what TTS engine is used and (sometimes) the length of text spoken.

 

200ms delay is noticeable to human caller.

 

It is not much of a delay, but for a system that feels very responsive to caller it is advised to remove any such delays where possible. For this reason we recommend to use .WAV files in situations where the sound played does not change from call to call. .WAV files do not have any delay when they are played.



#15 ApexData 30 December 2016 - 12:17 AM

The 7.5.8_161209 version DID fix the issue with the TTS play in the GetNumber module.

Now for the next issue..I don't know if this is strictly related to Windows 10 so I'll post it here.

During all my testing on the Windows 10 PC, I have had sporadic issues with calls not being answered when the PC is first booted.  Sometimes the IVR Service will stop during the startup process.  Most of the time everything looks normal (Dialogic System Service and IVR Service say running) but it will not answer calls.  If I stop and start the IVR Service it still won't answer calls.  I have to stop the IVR Service, restart the Dialog System Service and then start the IVR Service to get it working.  I have attached the only logs that have the correct date stamp to see if they provide any helpful info. 

 

 

 

 

 



#16 SupportTeam 30 December 2016 - 02:45 AM

The 1229_ktTel.txt file posted seems to be a trace excerpt, not the full file.

Could you please post the full ktTel trace file, which captures the system startup as well.



#17 ApexData 30 December 2016 - 05:38 AM

The 1229_ktTel.txt that was posted was the complete file sitting in the logs folder.

I have attached the ktTel that is now sitting in the logs folder which includes stop/starts etc.



#18 SupportTeam 30 December 2016 - 07:08 AM

The startup process looks fine.

 

Was a problem experienced during either of the two startups captured?

 

 

If you needed to restart the Dialogic service to get things working before then this suggests the issue is with the Dialogic service.

 

Maybe try to set the VoiceGuide IVR service and the Dialogic service startup type to be: "Automatic (Delayed Start)".

 

This can be set in Windows' Control Panel -> Administrator -> Services applet.



#19 ApexData 30 December 2016 - 09:25 AM

Both services were changed to 'automatic delayed start'.

First time I rebooted it worked fine.

Second time the IVR Service stopped while the Dialogic said running.



#20 SupportTeam 30 December 2016 - 04:36 PM

Could you please post the ktTtel trace from that day and indicate the time of reboot when the issue occurred.

 

Was the reboot a full 'power off/of' reboot or a wake-up form "hibernation"/"sleep" ?



#21 ApexData 06 January 2017 - 03:31 AM

Did some further testing...below is the timing and steps:

 

11:51 Power up unit (from off state)

Dialogic running, VG stopped

11:53 Manually started VG

11:54 Call and no answer

11:56 Start/Stop VG.  

11:58 Call and still no answer.

11:59 Stop VG and Restart Dialogic

12:00 Start VG

12:01 Call. Answered but just a brief noise ?

12:02 Call and OK.

12:06 Restart Windows

Dialogic running. VG Stopped.

12:09 VG started on it's own after a couple of minutes.

12:10 Call and works.

12:12 Shutdown Windows

12:13 Powered up unit (from off state)

Dialogic running and VG running.

12:14 Call and no answer.



#22 SupportTeam 06 January 2017 - 06:37 AM

At 11:53 the VoiceGuide service started fine and communicated with the Dialogic drivers as expected, but VoiceGuide received no alerts of any incoming calls at 11:54 or at any other time. Traces show the VoiceGuide service was then stopped at 11:56.

 

When you say that system was "Power up unit (from off state)" it sounds like the system was not in actual "power-off" state, but in "Hibernation" state. The behavior that you describe occurs if Windows places system in "Hibernation'. Dialogic drivers do not support Hibernation.

 

Suggest ensuring that system cannot ever enter "Hibernation" state.

As system running an IVR service is usually left ON permanently, so these type of situations are not usually encountered in live systems.



#23 ApexData 06 January 2017 - 07:54 AM

The unit was completely powered down before starting.

All setting were previously changed to not allow hibernation.

I understand that the system normally would operate 24x7 without being powered down.

However, if it does (power failure, windows updates, etc.) it appears the user would have to intervene to get the system working again.

To get it working, I have to:

1) Stop the VG Service

2) Stop the Dialogic Service

3) Start the Dialogic Service

4) Start the VG Service 



#24 SupportTeam 06 January 2017 - 08:08 AM

Are the Dialogic and VoiceGuide services now set to startup in "Automatic" mode, or "Automatic (Delayed Start)" ?

 

if not set to "Automatic (Delayed Start)" then please set them both to "Automatic (Delayed Start)" and then perform the power-down and power-up cycle again.

 

(Service startup type is settable in in Windows' Control Panel -> Administrator -> Services applet.)



#25 ApexData 06 January 2017 - 08:53 AM

Yes, both services were already set to 'Automatic (Delayed Start)'.



#26 SupportTeam 06 January 2017 - 09:29 AM

Could you please advise what is the "OS Build" version of Windows 10 on this system ?

Could you please open a Command Prompt and run this command:

 

systembuild

 

systeminfo

 

and post the output of that command here.


Edited by SupportTeam, 07 January 2017 - 02:34 AM.
fixed the command to use


#27 ApexData 06 January 2017 - 09:53 AM

systembuild is not a valid command.

 

Windows Update history tells me Windows 10 Version 1607.



#28 ApexData 06 January 2017 - 10:00 AM

Edition: Windows 10 Pro

Version: 1607

OSBuild: 14393.351



#29 SupportTeam 07 January 2017 - 02:35 AM

The command is:

 

systeminfo

 

Please post the output when above command is ran in Command Prompt.



#30 ApexData 07 January 2017 - 10:16 AM

systeminfo displays:

10.0.14393  N/A  Build 14393



#31 SupportTeam 07 January 2017 - 05:47 PM

systeminfo should show a whole page of information.

 

Please post the entire output of systeminfo



#32 ApexData 08 January 2017 - 01:15 AM

Host Name:                 APEXIVR
OS Name:                   Microsoft Windows 10 Pro
OS Version:                10.0.14393 N/A Build 14393
OS Manufacturer:           Microsoft Corporation
OS Configuration:          Standalone Workstation
OS Build Type:             Multiprocessor Free
Registered Owner:          N/A
Registered Organization:   N/A
Product ID:                00330-50294-10335-AAOEM
Original Install Date:     10/31/2016, 10:29:21 AM
System Boot Time:          1/5/2017, 12:06:34 PM
System Manufacturer:       Dell Inc.
System Model:              OptiPlex 5040
System Type:               x64-based PC
Processor(s):              1 Processor(s) Installed.
                           [01]: Intel64 Family 6 Model 94 Stepping 3 GenuineIntel ~3408 Mhz
BIOS Version:              Dell Inc. 1.4.5, 6/27/2016
Windows Directory:         C:\Windows
System Directory:          C:\Windows\system32
Boot Device:               \Device\HarddiskVolume1
System Locale:             en-us;English (United States)
Input Locale:              en-us;English (United States)
Time Zone:                 (UTC-05:00) Eastern Time (US & Canada)
Total Physical Memory:     16,269 MB
Available Physical Memory: 14,386 MB
Virtual Memory: Max Size:  18,701 MB
Virtual Memory: Available: 16,656 MB
Virtual Memory: In Use:    2,045 MB
Page File Location(s):     C:\pagefile.sys
Domain:                    WORKGROUP
Logon Server:              \\APEXIVR
Hotfix(s):                 3 Hotfix(s) Installed.
                           [01]: KB3199986
                           [02]: KB3201860
                           [03]: KB3197954
Network Card(s):           1 NIC(s) Installed.
                           [01]: Intel® Ethernet Connection (2) I219-V
                                 Connection Name: Ethernet
                                 DHCP Enabled:    No
                                 IP address(es)
                                 [01]: 192.168.1.225
Hyper-V Requirements:      VM Monitor Mode Extensions: Yes
                           Virtualization Enabled In Firmware: Yes
                           Second Level Address Translation: Yes
                           Data Execution Prevention Available: Yes

 



#33 SupportTeam 08 January 2017 - 01:37 AM

VoiceGuide logs show that this system has two D/4PCIU cards installed in it.

Serial numbers on cards suggest the cards are quite new, so would recommend raising the Dialogic driver restart issue through supplier of these Dialogic cards.

 

Are you able to try using Win2008 or Win2012 on this system instead and see if system startups correctly from a power reset when using Win2008 or Win2012 ?



#34 SupportTeam 22 April 2017 - 05:47 PM

Please note below that also applies to Windows 10:

 

When using Dialogic cards, Windows' "Power Management" is not supported and must be disabled

 

Failure to disable Power Management could cause the system to crash upon resuming from Sleep or Hibernation states.

 

 As part of Power Management, what is known as "Hybrid Shutdown" or "Fast Boot" is also not supported and must be disabled.

 

It is also recommended that Microsoft’s User Account Control is disabled, as under some conditions it has been shown to cause intermittent audio gaps when playing audio.