Jump to content


< Back to Forum


 

Recording Two Channels Same Time


  • Please log in to reply

#1 Maciej 05 December 2016 - 11:40 PM

We need to record separated channels to two files.

 

We try to use script below:

set vg = CreateObject("vgServices.CommandLink")

vg.Admin_TraceLogAdd $RV[Conf_LineId_1], 0, "rec_2lines $RV[session_id] call"

'strRet = vg.Record_2Lines_Start($RV[Conf_LineId_1], $RV[Conf_LineId_1], $RV[Conf_LineId_2], "C:\callrecord\$RV[session_id]_$RV_HH$RV_NN$RV_SS.wav", "")

vg.Record_Start $RV[Conf_LineId_1], "channel_L.wav", 0
vg.Record_Start $RV[Conf_LineId_2], "channel_R.wav", 0

'vg.Admin_TraceLogAdd $RV[Conf_LineId_1], 0, "rec_2lines $RV[session_id] returned"

vg.Run_ResultReturn $RV[Conf_LineId_1], "success"

set vg = Nothing

two test calls shows:

 

channel_L.wav is long 2,988 sec and no sound recorded (silence)

channel_R.wav  has full record of Agent side conversation duration (32 sec).



#2 SupportTeam 06 December 2016 - 06:59 AM

Please post the ktTel trace file from 5th December for this system.We can then see what is happening on this system and comment.



#3 Maciej 06 December 2016 - 10:17 PM

attached



#4 SupportTeam 07 December 2016 - 05:34 PM

The recording on line 1 stopped due to silence being detected on that line:

 

819 135650.138  5076   3 ev    TDX_RECORD (Record Completed)
820 135650.140  5076   2       termmask=TM_MAXSIL (hli->linedev=2)
821 135650.140  5076   2       Event_Silence begin
822 135650.140  5076   2 r     Silence

 

Is it possible that there was silence on that line after the recording commenced?

 

You can try disabling silence detection in VG.INI, in section [PlayRecordConfig] set entry SilenceDetectLevel to 0, like this:

 

SilenceDetectLevel=0

 

Silence detection level setting (or disabling) can also be done from within the script. Please see: http://www.voiceguid...l/modrecord.htm