Jump to content


< Back to Forum


 

Sip Registration Not Working


  • Please log in to reply

#1 leopard 23 November 2017 - 06:25 AM

Using HMP on windows 10 Pro 32-bit.

 

Dialogic service and voiceguide service are started successfully.

 

But I am unable to receive calls and my SIP provider says they do not see my registration appearing on their end.

 

What am I doing wrong?

 

Below are the changes I made to config.xml. 

<VoIP_Registrations>

<VoIP_Registration>
<Display>Test</Display>
<Protocol>SIP</Protocol>
<RegServer>sip2.jivetel.com</RegServer>
<RegClient>ciscotest@sip2.jivetel.com</RegClient>
<LocalAlias></LocalAlias>
<Expires>60</Expires>
</VoIP_Registration>

</VoIP_Registrations>

<VoIP_Authentications>

<VoIP_Authentication>
<Display>Test</Display>
<Realm></Realm>
<Identity></Identity>
<AuthUsername>ciscotest</AuthUsername>
<AuthPassword>d97ftda6-637c-9aa2-b</AuthPassword>
</VoIP_Authentication>

</VoIP_Authentications>


#2 SupportTeam 23 November 2017 - 07:33 AM

Please uninstall the Dialogic HMP drivers which you currently have installed on this system and install the Dialogic HMP drivers which are available for download from the VoiceGuide Downloads page.

 

You must use the correct version of HMP Drivers for which each particular version of VoiceGuide was built for.

 

When uninstalling HMP do not save any configuration data and restart Windows after the uninstall and after the install.

 

 

If you still encounter issues then could you do a WireShark (www.wireshark.org) capture of SIP traffic on this system to see what SIP packets are being sent/received and post the WireShark trace along with the VoiceGuide traces.



#3 SupportTeam 23 November 2017 - 08:50 AM

The ktTel trace shows that the error during registration was:  IPEC_REG_FAIL_invalidAlias

 

Please set the <LocalAlias></LocalAlias> entry in Config.xml to this format:

 

<LocalAlias>ciscotest@YOUR_LOCAL_IP_ADDRESS</LocalAlias>

 

 

ktTel excerpt:

186 120929.777  4620           GCEV_SERVICERESP ResultInfo: gcValue=1283(0x503|GCRV_PROTOCOL|event caused by protocol error) gcMsg=[Event caused by protocol error] ccLibId=8 ccLibName=[GC_H3R_LIB] ccValue=[0x66||] ccMsg=[IPEC_REG_FAIL_invalidAlias] additionalinfo=[]
187 120929.777  4620           ccValue!=IPERR_OK (VoIPProvider_AuthenticationSet)


#4 SupportTeam 23 November 2017 - 12:07 PM

Also, looks like the version of VoiceGuide installed on this system is not the latest version (it is a recent version but a newer version has been released since)

 

Please update VoiceGuide to latest version available for download, and post traces from this newest version if you still encounter issues.

 

 

 

To change from one release of VoiceGuide v7 to another:

1. Stop VoiceGuide Service and exit all VoiceGuide programs. (eg Script Designer, etc) and all other programs.

2. Run the VoiceGuide install and install into same directory as existing installation, over the top of the existing installation. (Do NOT uninstall the previous VoiceGuide installation).

3. Start  VoiceGuide service.

Running a VoiceGuide install over the top of an existing install will NOT overwrite existing configuration or license files (Config.xml, ConfigLine.xml, VG.INI, VmBoxList.xml, etc) and will not remove any of users script or sound files, and will not remove any log files etc.