Jump to content


< Back to Forum


 

Voidceguide 7 Sip Trunk


  • Please log in to reply

#1 Diego Miņo 14 April 2015 - 06:47 AM

Hello Voiceguide 7 supports SIP TRUNK?
you have a sample configuration file?

SAludos
Diego



#2 SupportTeam 14 April 2015 - 07:24 AM

Yes, VoiceGuide v7 works with SIP trunks.

 

The Config.xml file would not need to be changed to have VoiceGuide/HMP work with SIP trunks. The SIP trunk routing is usually just set up to point to IP address of the VoiceGuide system, and then VoiceGuide will answer any calls arrive. And outgoing calls are just routed through the SIP trunk's IP address.

 

Also, most SIP trunks are setup without requiring any registration/authentication, but you should contact your SIP trunk provider to confirm that.

If registration/authentication is required for the SIP trunk then this is set in Config.xml in usual manner.



#3 Diego Miņo 29 April 2015 - 04:02 AM

Ready, enter the inbound calls correctly.
But how I can make the Outbound call?

My PBX is ALCATEL OXE

How I place the number to dial?
The PBX is my ip 192.168.2.60

 

Br

 

Diego

  • llamada inbound voice.JPG
  • llamada outbound.JPG


#4 SupportTeam 29 April 2015 - 07:04 AM

Can you please post the vgEngine and ktTel trace files that capture system startup and an outgoing call or transfer being loaded/made.

 

We can then see what is happening on the system and advise.



#5 Diego Miņo 29 April 2015 - 08:36 AM

I am attaching the logs

  • Attached File  log.zip   97.43KB   69 downloads


#6 SupportTeam 29 April 2015 - 09:39 AM

WireShark trace shows that the SIP switch at 192.168.2.60 (OmniPCX Enterprise R11.0 k1.400.30.f) replies with "480 Temporarily not available'.

 

You would need to look at the OmniPCX logs to establish why it chooses to answer an incoming INVITE with a 480.

 

Have you tried dialing extension 8948 from another extension on this PBX to confirm that 8948 works and calls to it can be answered?

 

Have you tried getting VoiceGuide to dial a different extension?

 

Also, can you please capture the WireShark trace of a call sent from OmniPCX to VoiceGuide (we can see that those calls are answered OK by VoiceGuide). We will then be able to see how the OmniPCX sends calls and that may shed some light on the problem.

  • outgoingcall.png


#7 Diego Miņo 30 April 2015 - 06:31 AM

I attach files for a inbound call.

br

Diego



#8 SupportTeam 30 April 2015 - 07:12 AM

Incoming call looks fine; pretty standard SIP with A-Law encoding used for the voice traffic.

 

Have you done the tests on the 8948 extension as advised previously or tried dialing a different extension?

  • incoming_pcap.png


#9 Diego Miņo 30 April 2015 - 08:36 AM

how to disable authentication for voice guide or hmp?

 

br

 

Diego

  • log voiceguide.JPG


#10 SupportTeam 30 April 2015 - 10:04 AM

Look like PBX is requesting Registration/Authentication in order to proceed with outgoing call.

 

Do you have the user and/or password information required to authenticate outgoing calls through your PBX?

 

Information on configuring Registration/Authentication in VoiceGuide is here:

 

http://www.voiceguid...ip_register.htm

 

Can you please post the actual .pcap trace file from WireShark (.ZIPed).

 

The .pcap trace file contains the information that would need to see to confirm what you need to specify in VoiceGuide's Config.xml



#11 Diego Miņo 01 May 2015 - 12:22 AM

Hello, the PBX does not require Registration / Authentication,
the logs are attached, and config.xml and wireshark

 

PBX 192.168.2.60

 

VOICEGUIDE and HMP 192.168.1.147

 

regards
Diego



#12 SupportTeam 01 May 2015 - 07:42 AM

The PBX is answering the INVITE request with a "407 Authentication Required". Both the screenshot you supplied yesterday and the traces supplied today show this. (today's trace screenshot attached as well).

 

Digest Authentication asked for in the 407 message shows realm="oxe" and the nonce is provided, so it is a valid 407.

 

You would need to to check with OmniPCX admin as to why the OmniPCX is sending the 407 message and what are the Authentication details that re required by the OmniPCX.

  • 407 response.png


#13 Diego Miņo 05 May 2015 - 06:42 AM

Hello, the idea is to use the SIP TRUNK.
IN the PXB not enabled authentication,
It is without authentication.

the config.hml file is only when using SIP extensions?
  You can configure SIP TRUNK.?

I think we need to create or register a extension in voiceguide
  xxxx@192.168.1.147 example: 5060 side VOICEGUIDE

 

br

 

Diego

  • voice.JPG


#14 SupportTeam 05 May 2015 - 08:01 AM

Using a SIP trunk is fine. It is the approach we recommend using. There is no special configuration required in order for VoiceGuide to use SIP trunks, it works out of the box.

 

If you think that your PBX needs for VoiceGuide to register itself as an extension and then send outgoing calls using the CallerID of the registered extension, then this can be achieved by specifying the extension registration data in Config.xml. Please see: http://www.voiceguid...ip_register.htm for instructions on registering an extension.

 

Then, when placing outgoing calls the outgoing CallerID can be set using the <CallerID> setting in the outgoing call's Options. Please see: http://www.voiceguid...l/dial_voip.htm

 

You already have incoming calls arriving into VoiceGuide over the SIP trunk without registering an extension, so it would be unusual that an extension needs to be registered to perform outgoing calls, but you can certainly try to use this approach.