Jump to content


< Back to Forum


 

Ports


  • Please log in to reply

#1 luisr 16 May 2015 - 10:37 AM

To make some calls, where he indicated that harbor, I say to use the one and two-and uses all that can be?

 

I have the version 7.4.5



#2 SupportTeam 17 May 2015 - 04:41 PM

Could you please explain in more detail what problem you are encountering.

 

If it makes it easier please write in your own language and we can use Google translate or similar.



#3 luisr 20 May 2015 - 12:16 AM

Tengo instalada la versión 7.4.5 en cuatro puertos

 

Pero tengo el problema de que al generar unas llamadas, le indico que puertos usar, por ejemplo 1 y 2

Pero las llamadas salen por los cuatro puertos

Según yo, se le indica porque puertos escribiendo los números y separados por comas, pero no lo respeta

Que me faltara de configurar o como le podre hacer?

 

Gracias



#4 SupportTeam 21 May 2015 - 09:01 PM

I have version 7.4.5 installed on four ports

But I have the problem that when generating some calls , I am indicating that ports used, for example 1 and 2

But calls out the four ports

As I was writing it indicates that port numbers separated by commas , but not respected

I lacked setting or as pus do?

 

 
Can you please advise how are you loading new calls into the system, are you using the VoiceGuide Call Loader or some other method?

 

Can you please post the vgEngine trace that captures system startup and a few calls being made, and indicate which of the calls is made on the wrong port. We can then look at that call and advise what happened.



#5 luisr 24 May 2015 - 05:29 AM

Si estoy usando el software VoiceGuide Call

 

De lo que me piden, lo podre sacar de algún archivo blog?



#6 SupportTeam 24 May 2015 - 06:58 AM

If I am using the software VoiceGuide Call

What they ask me , I will be able to take some blog file?

 

Can you please describe in full what you are trying to achieve and/or what problems you are encountering.

 

The Google translation above is probably not correctly conveying the meaning of your question.

 

The vgEngine trace files can be found in VoiceGuide's /log/ subdirectory.



#7 roman 26 May 2015 - 07:13 AM

Let me restate the question. We are using the Outboundloader to activate campaigns. In the Scheduling tab, in the textbox named "Only call on these ports", We indicate the ports we want to make calls (example; 1,2). This indications is ignored, VoiceGuide Process calll on all ports (4). Also. If I select the campaign and push the "Pause", "Activate" and "Delete" buttons they are ignored. The versi{on of VG is 7.4.5584 and is working with Mysql 5.6.

 

Thanks for your comments.



#8 SupportTeam 26 May 2015 - 08:16 AM

Could you please post the vgEngine and the vgDialListLoad traces that capture VoiceGuide service start, call being loaded and some of the calls being made. We can then see what is happening on the system and advise.

 

The traces are saved in VoiceGuide's \log\ subdirectory.



#9 SupportTeam 27 May 2015 - 11:43 AM

It looks like there is an error in the Config.xml file that stops VoiceGuide from using the port selection feature. (ie stops VoiceGuide from using the "PortToUse" table).

 

In Config.xml please make sure that the OutDialQue_PortToUse_LinkField field is set to ID. ie:

 

<OutDialQue_PortToUse_LinkField>ID</OutDialQue_PortToUse_LinkField>

 

(it is currently set to 3306, which is an invalid entry that does not do anything)

 

 

Also please update system to this version which should fix the activate/pause/delete buttons:

 

[old link removed]

 

 

 

To change from one release of VoiceGuide v7 to another:

 

1. Stop VoiceGuide service and exit all VoiceGuide programs. (eg Script Designer, Voicemail Manager, etc) and all other programs.

2. Run the VoiceGuide install and install into same directory as existing installation. (Do NOT uninstall the previous VoiceGuide installation).

3. Start VoiceGuide service.

 

Running a VoiceGuide install over the top of an existing install will NOT overwrite existing configuration or license files (Config.xml, ConfigLine.xml, VG.INI, VmBoxList.xml, userinfo.lic) and will not remove any of users script or sound files, and will not remove any log files etc.

Please note however that the local SQLite outdial database will be re-initialized. If you are using the local SQLite outdial database and have any queued outgoing calls that you would like to keep then this database should be backed up first.

 

 

As you have setup your own MySQL database, and are not using the default SQLite then you may need to clean out the old entries from PortToUse table.

 

Please let us know if you have any questions,

165453.179   6               db    config OutDialQue_ADODB_Provider = MySql.Data.MySqlClient
165453.179   6               db    config OutDialQue_Database = vgDb
165453.179   6               db    config OutDialQue_ConnectString.len = 84
165453.179   6               db    config OutDialQue_SqlPrefix = SELECT
165453.179   6               db    config OutDialQue_SqlSuffix = LIMIT 1
165453.179   6               db    config OutDialQue_PortToUse_LinkField = 3306
165453.179   6               db    config zConfigXml_sDialer_OutDialQue_porttouse_LinkField = 3306 (set in Config.xml)
103501.145   0       dial  cmd_callque_Insert ExecuteReader [014499755305,,guid_not_used,]
103501.146   0       dial  cmd_callque_Insert.ExecuteReader [014499755305] returned, some data FieldCount=1
103501.146   0       dial  dr[ID] : Could not find specified column in results: ID
103501.146   0       dial  dr[id] : Could not find specified column in results: id
103501.146   0       dial  cmd_callque_Insert.ExecuteReader [014499755305] sID=-1, oID=1509, iID=1509
103501.148           dial  Db_Insert_porttouse completed. values=1509,guid_not_used,14/05/2015 09:54:33 a.m.,iScheduler=0,sPortList=[1,2,3],iPriority=1, times=1,0,1,0,1,0,1,1900,1,0,1,0,1,0,   tel=014499755305, inserts=3, ts=00:00:00.0010000
165633.002  11               dial  state 1:Connected,2:Connected,3:Connected,4:Null,
165633.003  11               dial  db    do    findcall objDbDataReader_Stage2.iFieldCount=17, diff=00:00:00.0010000
165633.003  11               dial  db    do    findcall oOutCallData.guid is not used LinkField=[3306]
165633.003  11   7   4       dial  db    do    findcall (specific port) sDateTimeValue=14/05/2015 03:06:03 p.m. => 14/05/2015 03:06:03 p.m.
165633.003  11   7   4       dial  1509,,014499755305,14/05/2015 03:06:03 p.m.,BONIFICACION0514,priority=1,live=C:\Users\Iman-2\Desktop\Campa?as\Campa?a_1.vgs,am=C:\Users\Iman-2\Desktop\Campa?as\Campa?a_1.vgs,fax=,na=,exhausted=,20,count=3,delay=5,,,
165633.004  11               dial  callque update id/guid=1509/00000000-0000-0000-0000-000000000000 nextActivateTime=14/05/2015 05:01:33 p.m., retriesLeft=2, iRelatedPortNumber=4
165633.004  11               dial  cmd_UpdateDateAndRetries.ExecuteNonQuery call
165633.007  11               dial  callque update id/guid=1509/00000000-0000-0000-0000-000000000000 completed ok
165633.007  11   7   4       dial  call found (autodialer) ID/GUID=1509/00000000-0000-0000-0000-000000000000, tel=014499755305, SinceTaskLoaded=00:00:00.0050003, SinceWorkOnTaskStarted=00:00:00.0050003, S1=00:00:00 (000000.000-000000.000), S2=735731.16:56:33.0032219 (165633.003-000000.000), RetrUpdt=00:00:00.0030002 (165633.007-165633.004)
165633.008  11               q_scr +     cmdOutboundCallStart 0


#10 roman 05 June 2015 - 11:34 AM

Thanks for your reply. We apply the patch and is working much better. Still we have a strange behaivor, when VG redials a number that is not contacted in a previous attempt, it happens that redials but does so simultaneously in all available ports, ie, if there are three free port, i calls on all of them simultaneously. Could toy tell me if I need any extra configuration?

 

Thanks in advanced



#11 SupportTeam 05 June 2015 - 11:50 AM

Could you please post the vgEngine trace that captures this behavior. We can then see what is happening on the system and advise.



#12 SupportTeam 11 June 2015 - 03:02 PM

Trace shows many "Datetime function: datetime field overflow".

 

Looks like MySQL database was throwing an error and this caused the call the be seen as 'ready to dial' by other lines.

 

This version should fix this issue:

 

[old link removed]

 

 

 

To change from one release of VoiceGuide v7 to another:

 

1. Stop VoiceGuide service and exit all VoiceGuide programs. (eg Script Designer, Voicemail Manager, etc) and all other programs.

2. Run the VoiceGuide install and install into same directory as existing installation. (Do NOT uninstall the previous VoiceGuide installation).

3. Start VoiceGuide service.

 

Running a VoiceGuide install over the top of an existing install will NOT overwrite existing configuration or license files (Config.xml, ConfigLine.xml, VG.INI, VmBoxList.xml, userinfo.lic) and will not remove any of users script or sound files, and will not remove any log files etc.

Please note however that the local SQLite outdial database will be re-initialized. If you are using the local SQLite outdial database and have any queued outgoing calls that you would like to keep then this database should be backed up first.

 

 

As you have setup your own MySQL database, and are not using the default SQLite then you may need to clean out the old entries from PortToUse table.

 

Please let us know if you have any questions, and if you still encounter any issues please post traces as before.



#13 roman 18 June 2015 - 10:46 AM

Thanks, until now everything looks fine. I like to increase the number of ports in the same computer. nut I would like to know how use in these cases the license:

 

1.- I have to increase a card of the same type (4 ports ) or I can put a different one, for example 8 ports and different provider?

2.- By increasing the ports, I pay the difference in extra ports only? or I have to buy a new license for 8 ports?

 

I appreciate your feedback.



#14 SupportTeam 18 June 2015 - 11:00 AM

Simplest and cheapest option is to just add another card.

 

Multiple D/4PCI series cards (which are all 4 port cards) can be placed in the same system.

 

Multiple D/41JCT series cards (4 port cards) can be placed in the same system, but they need to be linked by a "CT-Bus" cable in order for them to work.

 

There are no 8 port cards. There is a 12 port card (D/120JCT) but please note that it is a 'full-length' type card, so your PC/Server needs to be able to accommodate that. Again, multiple D/120JCT cards can be placed in one system, but they need to be linked by a "CT-Bus" cable in order for them to work.

 

If you are looking at using more then 12 ports then yo may want to look at using T1 or E1 ISDN trunks (and the corresponding Dialogic D/240JCT and D/300JCT cards).

 

 

BTW. note that you cannot mix D/4PCI series cards and JCT series cards in same system.

 

 

You would only pay for additional ports if you continue to use the same software version. Please contact sales@voiceguide.com for all license related questions.



#15 roman 19 August 2015 - 01:56 AM

Hi SupportTeam

 

Until now I realice that my log sttoped working. It was working fine until I aplly this files, can you tell me how to active log again?

 

On the other hand, if I have to change my computer, I have to apply the files provided in this fórum in the same order? or just the last one?

 

Thanks in advanced



#16 SupportTeam 19 August 2015 - 09:25 AM

The logs can be disabled in VG.INI

 

Have you edited the VG.INI file?

 

Is there enough space on the hard disk?

 

Is there anything saved in VoiceGuide's \log\ subdirectory?

 

 

The last fix provided was a full install. You would just need to run that full install on your new computer.