Jump to content


< Back to Forum


 

Ivr Timeout After Few Hours (Sip System)


  • Please log in to reply

#1 yona 24 July 2015 - 06:02 AM

Hi,

 

I have 2 IVR Phone #'s set up.

 

The first # 646-883-0054 works fine.

 

The second # 646-570-1614 keeps on timing out. I need to restart the service in order to get it to work.

 

 

Attached are log files and the confix.xml. Is there anything I'm doing wrong?

 

I'd really appreciate any help you can offer.

 

 

Thanks a lot,

Yon



#2 yona 24 July 2015 - 07:02 AM

Sorry, attached is the config.xml



#3 SupportTeam 24 July 2015 - 08:19 AM

Traces show that VoiceGuide has not been configured to register to receive calls to 646-883-0054 or 646-570-1614 numbers.

 

VoiceGuide has only been configured to register to receive calls to the following 5 SIP numbers:

 

reg_server=callcentric.com, reg_client=17772952132@callcentric.com, local_alias=17772952132@192.168.0.120
reg_server=74.208.110.16, reg_client=1298@74.208.110.16, local_alias=1298@192.168.0.120
reg_server=74.208.110.16, reg_client=1198@74.208.110.16, local_alias=1198@192.168.0.120
reg_server=74.208.110.16, reg_client=1498@74.208.110.16, local_alias=1498@192.168.0.120
reg_server=74.208.110.16, reg_client=1398@74.208.110.16, local_alias=1398@192.168.0.120

 

So not sure how your SIP telephony solution has been set up, but VoiceGuide has not been configured to set up or maintain connectivity with either of the two numbers that you mention.



#4 yona 28 July 2015 - 02:30 AM

This is our registration with the company for our phone #: reg_server=callcentric.com, reg_client=17772952132@callcentric.com, local_alias=17772952132@192.168.0.120

 

This phone # works fine with VoiceGuide.

 

But after leaving it idle for a few hours it stops working.

 

Once I restart VoiceGuide it starts working again until the next timeout.

 

So the issue is not with the registration of the phone # - since it works for the first few hours, but there is something that causes it to time out.



#5 SupportTeam 28 July 2015 - 06:17 AM

Most likely there is a problem with SIP re-registrations.

 

Could you please use WireShark to capture the SIP registrations that are done by VoiceGuide at the service startup time and the re-registration requests that follow.

 

To filter for just the SIP packets type: sip in the WireShark's filter box.

 

Run WireShark for long enough to capture a number of re-registration requests.

 

Then please save the captured traffic (just the displayed packets) to a .pcap file and post the .pcap file here. (Please also .ZIP up any files before posting)

 

We can then see what is happening on the system and advise.



#6 SupportTeam 28 July 2015 - 05:00 PM

VoiceGuide/HMP uses the SIP re-registration timeout suggested by VoIP service provider.

 

This 'Expires' timeout is advised by VoIP service provider on Register confirmation (in the OK response). CallCentric usually sets Expires value to be 60, which results in Dialogic HMP sending out a new Register message every 30 seconds.

 

You should see this when you use WireShark to confirm what SIP packets are sent between VoiceGuide/HMP and CallCentric.

 

If CallCentric keeps acknowledging the register requests from VoiceGuide/HMP then that telephone number should function and you should see calls to that number being forwarded by SIP to VoiceGuide/HMP by CallCentric.

 

 

BTW: You also can try specifying the initial suggested re-register timeout in VoiceGuide's Config.xml using the <Expires> entry. Please see example below:

 

<VoIP_Registration>
  <Protocol>SIP</Protocol>
  <RegServer>callcentric.com</RegServer>
  <RegClient>17772952132@callcentric.com</RegClient>
  <LocalAlias>17772952132@192.168.0.120</LocalAlias>

  <Expires>60</Expires>
</VoIP_Registration>

 

VoiceGuide service would need to be restarted to read in the new <Expires> setting.

 

But it is usually not necessary to add the <Expires> entry to Config.xml as VoiceGuide will use whatever Expires setting is advised by VoIP service provider.
 

If possible please make two separate WireShark captures - one before this <Expires> setting is set in Config.xml, and one after adding the <Expires> setting to Config.xml, and please post both .pcap traces. We can then clearly see how the VoIP service provider is responding to SIP registration requests. 



#7 yona 29 July 2015 - 07:18 AM

Hi,

 

config.xml was modified to include <expires>60</expires>.

With this expiration setting it stops working after 30 seconds.

Looking at the wireshark log now, it doesn't look like it re-registers at all.

 

(I didn't test it before the expiration change, since I would have needed to wait a full day)

 

Attached is config.xml with the expiration change and the wireshark.



#8 SupportTeam 29 July 2015 - 07:43 AM

Looks like the files did not attach.

 

Can you please try attaching them again.



#9 yona 30 July 2015 - 12:38 AM

Sure Here they are.

 

Thanks a lot

  • Attached File  ivr.zip   2.57MB   70 downloads


#10 SupportTeam 30 July 2015 - 09:32 AM

The Config.xml in the ivr.zip file attached above specifies that the following 4 extensions are to be registered:

 

1198@74.208.110.16
1298@74.208.110.16
1398@74.208.110.16
1498@74.208.110.16
 

and the WireShark trace shows that all 4 registrations were done successfully (with the 3CX Phone System at 74.208.110.16)

 

The attached Config.xml does not specify any CallCentric numbers to register, and no CallCentric number registration requests are captured in attached trace.



#11 yona 31 July 2015 - 01:53 AM

1198@74.208.110.16
1298@74.208.110.16
1398@74.208.110.16
1498@74.208.110.16

 

The issue is with these numbers. as you can see in the wireshark log, its being registered and it works initially!

But after expiration, it's not being re-registered and STOPS working.

 

There is NO re-registration in the wireshark log after running for hours.

 

(We are not concerned about the callcentric. We have removed them.)



#12 SupportTeam 31 July 2015 - 07:16 AM

Can you please do the following:

 

1. add the entry to the CallCentric number (17772952132@callcentric.com)back to Config.xml and run the WireShark trace again and restart the VoiceGuide service.

 

and:

 

2. remove the <Expires> setting from 1198@74.208.110.16 and 1298@74.208.110.16 <VoIP_Registration> entries - just to confirm that that setting is not affecting anything.

 

 

Then after a few minutes please load outgoing call to the number:

 

1498@74.208.110.16

 

ans then load an outgoing call to number:

 

17772952132@callcentric.com

 

And please post the WireShark trace capturing the SIP registration and communications afterwards.

 

If the calls are successful (you should see calls arriving back at VoiceGuide and being answered by VoiceGuide) then wait a while longer and do the same thing later - and keep repeating the outgoing calls until the time when you no longer have calls arriving back at VoiceGuide. You can try waiting 10 minuter between outgoing calls, then half an hour, then and hour, then a few hours, etc.

 

Then please post the captured SIP trace here.

 

 

Also, in the initial post you mentioned that you had two numbers and one of the numbers was working one was not working:

I have 2 IVR Phone #'s set up.

The first # 646-883-0054 works fine.

The second # 646-570-1614 keeps on timing out. I need to restart the service in order to get it to work.

Can you advise how those two numbers were set up? Were they with another VoIP service?



#13 yona 04 August 2015 - 04:52 AM

Attached are the wireshark files.

 

I'm not sure what you mean with 'load outgoing calls' the problem is with incoming calls.

 

I tried calling into voiceguide with 1498@74.208.110.16 & 17772952132@callcentric.com. After 10 minutes 17772952132@callcentric.com was working and 1498@74.208.110.16 was not working and not coming into wireshark.

 

As can be seen in attached wireshark, 17772952132@callcentric.com keeps on being re-registered while 1498@74.208.110.16 does not.



#14 SupportTeam 04 August 2015 - 06:29 AM

WireShark trace shows that 1498@74.208.110.16 has the 'Expires' attribute set to 1800 by 3CX, as the <Expires> setting was removed from 1498@74.208.110.16's <VoIP_Registration> entry.

 

Can you please retain the <Expires>60</Expires> setting in the 1498@74.208.110.16's <VoIP_Registration> entry and restart the system.

 

Placing an outgoing call to 1498@74.208.110.16 from VoiceGuide will let us see what is the 3CXs response to this call attempt and this may let us see why the 3CX is not forwarding the INVITE to the VoiceGuide system when the call to extension 1498 is made.

 

Please make these changes and restart the VoiceGuide service and make calls as before (plus the outgoing calls) and post the WireShark capture.



#15 SupportTeam 04 August 2015 - 07:01 AM

To test if maybe the Realm setting has any effect on the 3CX registrations please use the following VoIP_Registrations/VoIP_Authentications entries for the 1298,1198 and 1498 extensions:

<VoIP_Registrations>
<VoIP_Registration>
  <Protocol>SIP</Protocol>
  <RegServer>74.208.110.16</RegServer>
  <RegClient>1298@74.208.110.16</RegClient>
  <LocalAlias>1298@192.168.0.120</LocalAlias>
</VoIP_Registration>
</VoIP_Registrations>
<VoIP_Authentications>
<VoIP_Authentication>
  <Realm></Realm>
  <Identity></Identity>
  <AuthUsername>1298</AuthUsername>
  <AuthPassword>3973388advan</AuthPassword>
</VoIP_Authentication>
</VoIP_Authentications>



<VoIP_Registrations>
<VoIP_Registration>
  <Protocol>SIP</Protocol>
  <RegServer>74.208.110.16</RegServer>
  <RegClient>1198@74.208.110.16</RegClient>
  <LocalAlias>1198@192.168.0.120</LocalAlias>
</VoIP_Registration>
</VoIP_Registrations>
<VoIP_Authentications>
<VoIP_Authentication>
  <Realm>3CXPhoneSystem</Realm>
  <Identity></Identity>
  <AuthUsername>1198</AuthUsername>
  <AuthPassword>3973388advan</AuthPassword>
</VoIP_Authentication>
</VoIP_Authentications>



<VoIP_Registrations>
<VoIP_Registration>
  <Protocol>SIP</Protocol>
  <RegServer>74.208.110.16</RegServer>
  <RegClient>1498@74.208.110.16</RegClient>
  <LocalAlias>1498@192.168.0.120</LocalAlias>
  <Expires>60</Expires>
</VoIP_Registration>
</VoIP_Registrations>
<VoIP_Authentications>
<VoIP_Authentication>
  <Realm>3CXPhoneSystem</Realm>
  <Identity></Identity>
  <AuthUsername>1498</AuthUsername>
  <AuthPassword>3973388advan</AuthPassword>
</VoIP_Authentication>
</VoIP_Authentications>


#16 SupportTeam 04 August 2015 - 09:49 AM

After making the above changes to Config.xml please do the following

 

Dialogic HMP service and VoiceGuide service must both be stopped.

 

You can enable HMP’s RTF log to collect more parameters from it.

 

We can look at these RTF logs as well to see if there is anything obvious showing up in them.
 

Dialogic's RTF logs can also be supplied to Dialogic to get them to advise the exact cause of HMP not issuing the Re-Register requests to system at 74.208.110.16

 

 

Windows XP, server 2003 and Server 2008 32bit

1.            Do the following to use the RTFConfigWin.xml attached.

                Go to C:\Program Files\Dialogic\cfg

                Backup existing RtfConfigWin.xml

                Replace it with attached RtfConfigWin.xml (unzip it first) the xml file contains logging flags to enable specific logging details

 

2.            Run the tool by issuing rtftool reload' after the modification - this will activate the new RtfConfigWin.xml file. Or restart Dialogic service, RtfConfigWin.xml will be read in on restart.

 

3.            Try to reproduce the issue while RTF log is activated.

 

4.            When the issue occurs, please immediately backup the log files

                Log files are available in C:\Program Files\Dialogic\log (multiple files)

 

Windows 7 and Server 2008 R2

1.            Do the following to use the RTFConfigWin.xml attached.

                Go to C:\ProgramData\Dialogic\HMP\cfg

                Backup existing RtfConfigWin.xml

                Replace it with attached RtfConfigWin.xml (unzip it first) the xml file contains logging flags to enable specific logging details

 

2.            Run the tool by issuing rtftool reload' after the modification - this will activate the new RtfConfigWin.xml file. Or restart Dialogic service, RtfConfigWin.xml will be read in on restart.

 

3.            Try to reproduce the issue while RTF log is activated.

 

4.            When the issue occurs, please immediately backup the log files

                Log files are available in C:\Program Files (x86)\dialogic\log (multiple files)



#17 yona 05 August 2015 - 03:25 AM

I've never done outgoing calls. What would be the best way to do that? (I'm not sure my license supports it)



#18 SupportTeam 05 August 2015 - 07:17 AM

To enable outgoing calls you can temporarily switch system into operating in Evaluation mode. To do this please rename userinfo.lic file and restart the VoiceGuide service.

 

Outgoing calls can be loaded using the Call Loader.

 

Load the outgoing number as:

 

1498@74.208.110.16

 

and in the Options text box (at the bottom of the 'Scripts' tab) please include a Caller ID specification, like this:

 

<CallerID>1198@74.208.110.16</CallerID>

 

There is no difference to SIP registration and incoming call handling when running in Evaluation mode.



#19 yona 11 August 2015 - 06:56 AM

I've done as instructed to place outgoing calls, however, as you can see in the outbound call loader logs below, the call never went through:

 

following are pics of steps I've taken:

 

line status - https://gyazo.com/83...f910ad40ef92cfc

 

Contacts - https://gyazo.com/1b...a8b282ad383f2e2

Scripts - https://gyazo.com/70...f74c81fd5b66ca5

Scheduling- https://gyazo.com/2b...bdf63e2f2cc7010

Rules - https://gyazo.com/a9...7e1700bb242c88e

Reports - https://gyazo.com/7e...dc16219d7e523ee

SQL - https://gyazo.com/a2...13c529ae21029f9



#20 SupportTeam 11 August 2015 - 08:03 AM

The number to dial has to be:

 

1498@74.208.110.16

 

not

 

3476837830

 

If you are trying to dial 3476837830 though the 3CX system then that number should  loaded in as :

 

3476837830@74.208.110.16

 

or

 

13476837830@74.208.110.16

 

 

Also, for outgoing calls you will need to specify through which registered account that call is to be made, so you need to specify the CallerID.

 

in the Options text box (at the bottom of the 'Scripts' tab) please include a Caller ID specification, like this:

 

<CallerID>1198@74.208.110.16</CallerID>

 

Attaching your screenshots below:

  • tab_contacts.png
  • tab_scripts.png


#21 yona 12 August 2015 - 03:37 AM

I tried the following but the call still didn't go through.

(I tried these 2 legitimate phone #s before trying the 1498@74.208.110.16 that you gave me to see if the call goes through at all.)

 

Screenshots of how it was set up:

Contacts: https://gyazo.com/65...6853691d14642c8

Scripts: https://gyazo.com/3c...7a88ca6fabff499

Scheduling: https://gyazo.com/06...ccb401ffc04fed7

Rules: https://gyazo.com/af...7aedd11d680f34b

Reports: https://gyazo.com/6c...8f9281020e2960c

SQL: https://gyazo.com/bf...e981fc1f235d279

 

Attached are also the ivr log files.

 

 

 



#22 SupportTeam 12 August 2015 - 01:41 PM

We can see in trace:

123550.864   7   3   1 VG Dialer option not enabled

The release that is installed right now on this system has a bug that prevents the Dialer from working in Evaluation mode.

 

Can you please update this system to v7.5 to allow you to run the tests.

 

Afterwards you will be able to just install v7.4.5 again over the top to get back to using your current version.

 

 

To change from one release of VoiceGuide v7 to another:

1. Stop VoiceGuide Service and exit all VoiceGuide programs. (eg Script Designer, Voicemail Manager, etc) and all other programs.

2. Run the VoiceGuide install and install into same directory as existing installation. (Do NOT uninstall the previous VoiceGuide installation).

3. Start  VoiceGuide service.

 

Running a VoiceGuide install over the top of an existing install will NOT overwrite existing configuration or license files (Config.xml, ConfigLine.xml, VG.INI, VmBoxList.xml, etc) and will not remove any of users script or sound files, and will not remove any log files etc.



#23 yona 13 August 2015 - 01:04 AM

What would be the problem with staying with version 7.5?



#24 SupportTeam 13 August 2015 - 11:06 AM

v7.5 needs a different license. Please contact sales@voiceguide.com regarding all license related questions.



#25 yona 14 August 2015 - 06:09 AM

I loaded outgoing calls to  1498@74.208.110.16 & 17772952132@callcentric.com as instructed.

 

1498@74.208.110.16 worked.

17772952132@callcentric.com didn't work.

 

Attached are the log files along with the wireshark capture.



#26 SupportTeam 14 August 2015 - 07:19 PM

Looks like the Config.xml was not set as per port #15 in this thread ( http://voiceguide.co...2032#entry40787 ). The <Expires> entry was not set for 1498, and the <Realm> entries were not set for 1198 and 1498. As the <Expires> entry was not set, Dialogic HMP defaulted to 3600 seconds for the "Expires" setting, and 3CX did not propose its own value for that setting at any time.

 

No RE-REGISTER messages were issued by HMP at 1800 seconds after original register, as would have been expected.

 

 

Outgoing call was made at about 600 seconds after initial REGISTER.

 

3CX did route the call back to HMP, but after HMP responded with OK to the incoming call the 3CX never replied with an ACK - hence that call was never regarded as connected.

 

 

Perhaps a better way to connect 3CX to HMP is via a 'trunk' instead of multiple extensions all pointing to Dialogic HMP's IP address. It's possible that 3CX does not like having multiple extensions all under the same IP address (or MAC address?)

 

Would recommend to set up a trunk on the 3CX that just points to HMP/VoiceGuide system IP address. Trunks do not usually need to be registered, so that approach should be easier to work with.



#27 yona 24 December 2015 - 01:33 AM

 

Perhaps a better way to connect 3CX to HMP is via a 'trunk' instead of multiple extensions all pointing to Dialogic HMP's IP address. It's possible that 3CX does not like having multiple extensions all under the same IP address (or MAC address?)

 

Would recommend to set up a trunk on the 3CX that just points to HMP/VoiceGuide system IP address. Trunks do not usually need to be registered, so that approach should be easier to work with.

 

The provider told me they cant setup a trunk 

What they did advice is to use a outbound proxy to register 

I have no idea how to do this. can you advice 



#28 SupportTeam 24 December 2015 - 08:35 AM

Reading back through this thread it looks like:

 

 

1. you have a CallCentric number that works with no problems (17772952132@callcentric.com)

2. you have a series of 'extensions' registered with a VoIP service at 74.208.110.16

 

 

3. you have a 646-883-0054 number that arrives at VoiceGuide over the 17772952132@callcentric.com connection.

 

4. you have a 646-570-1614 number that arrives at VoiceGuide over one of the extensions from the service at 74.208.110.16.

 

 

5. calls to 646-883-0054 always arrive at VoiceGuide system, as the CallCentric service keeps on re-registering itself correctly.

6. calls to 646-570-1614 stop arriving at VoiceGuide system after a while as re-registration with 74.208.110.16 is not made after a while.

 

 

Is the above a correct summary of what you are seeing on your system?

What company is providing the VoIP service from IP 74.208.110.16 ?



#29 yona 24 December 2015 - 09:22 AM

Is the above a correct summary of what you are seeing on your system?

 

Yes

 

What company is providing the VoIP service from IP 74.208.110.16 ?

 

3CX



#30 SupportTeam 24 December 2015 - 09:44 AM

3CX supports trunks that route direct to an IP address.

 

Suggest that on the 3CX system you set up a trunk that points direct to the VoiceGuide system, and then add appropriate call rules that will route calls down that trunk to the VoiceGuide.

 

Here is relevant documentation from 3CX themselves:

 

http://www.3cx.com/d...der-sip-trunks/

 

http://www.3cx.com/d...unk-management/



#31 yona 24 December 2015 - 10:20 AM

OK I will fwd this.

How would I then setup the config.xml?

 

 

Thanks for your help.  



#32 SupportTeam 24 December 2015 - 10:45 AM

How would I then setup the config.xml?

 

Remove all 74.208.110.16 entries from Config.xml.

No registration and authentication of any type would be needed to receive calls from 74.208.110.16.

(CallCentric related entry should stay)

Calls will just arrive at VoiceGuide IP address and VoiceGuide will answer all calls arriving at it's IP address.


Edited by SupportTeam, 25 December 2015 - 07:21 AM.


#33 yona 25 December 2015 - 12:54 AM

a.  I need some lines to run one script and other lines running other scripts.

b.  I also have other providers not 3CX only

c. even with 3CX I would need to know what number was dialed



#34 SupportTeam 25 December 2015 - 07:23 AM

The system will still see what numbers were dialed and will be able to run different scripts depending on what number was dialed.

 

Multiple providers can send calls to the system at the same time

 

CallCentric related entry should stay in Config.xml (previous answer was now edited to make that clear).



#35 yona 25 December 2015 - 08:23 AM

What variable would i need to check to figure out what DID the client dialed?

Will i need a stub script to direct the call?



#36 SupportTeam 25 December 2015 - 08:31 AM

$RV_DNIS

 

A small scirpt (one 'Evaluate Expression' module) would route to other scripts depending on what value is held by $RV_DNIS



#37 yona 25 December 2015 - 09:20 AM

Thanks.  



#38 yona 25 December 2015 - 09:24 AM

on what port is VG listening ?



#39 SupportTeam 25 December 2015 - 09:40 AM

UDP 5060