Jump to content


< Back to Forum


 

Out-Going Calls With Call Coverage Setup


  • Please log in to reply

#1 bpolack 31 July 2015 - 05:16 AM

We are using VG 7.5 with a 12 port Dialogic D/120JCT LS board.  Only outgoing calls are made.  We have four phone lines, of which one is not being detected as a valid line by VoiceGuide.  (In the CallEvents log we see "working phone line not attached"  and can view call processing via the line monitor but a call is never made to the phone).

 

We have tested the board port and have validated that calls can be made from the "bad" line (by hooking the phone line to a phone and making calls out).  This line is set up in the coverage path for another line, as previously in-coming calls were set u, but are no longer done.  Why can't VoiceGuide detect that a valid line is attached to the port?  I have attached log files. 



#2 SupportTeam 31 July 2015 - 07:48 AM

Trace shows that when an outgoing call is attempted on port 4 the following error is raised:

 

ALERT Loop current not present. Working phone line not attached.

 

So either the line currently attached to port 4 on this system has a break in it, or the port on the Dialogic card is faulty.

 

You mention that:
 

We have tested the board port and have validated that calls can be made from the "bad" line (by hooking the phone line to a phone and making calls out).

 

So sounds like you have you been able to place outgoing calls over port 4 when some other line was attached to that port?

 

Please try unplugging the line cable from port 4 and plugging it into (say) port 1, and attaching the cable that was in port 1 into port 4. And then try placing outgoing calls to both ports again. If port 1 is now having problems instead (and port 4 works fine) then you have shown that the problems is in the line wiring, and that the cable that attached to port 4 originally needs to be replaced.

 

Is the problem intermittent at all? Solid copper wires can develop hairline fractures if they have been bent a number of times, and this is the most common cause of intermittent type problems.

085831.041  25   6   4 ev    Dialogic 135,RLS_LCSENSE, crn=20000004, 0,0,0,DX_OFFHOOK,CALL_OUTBOUND,ALERT Loop current not present. Working phone line not attached.
    Line 1066: 085830.501   8   4   3 ev    ktTel_Completion (generic) 10000 0,Completion_MakeCall, crn=20000003, 536870915,0,0,96149406824,,<result>ok</result><crn>536870915</crn><crnx>20000003</crnx>
    Line 1067: 085830.501   8   4   3       q_scr +     evktTelCompletion 0 Completion_MakeCall
    Line 1079: 085830.509   7   4   3       q_scr run   evktTelCompletion sCode=[Completion_MakeCall] iActionID=0, crn=0 [536870915|0|0|0|0][96149406824||<result>ok</result><crn>536870915</crn><crnx>20000003</crnx>|||] 00:00:00.0080008 max:3|00:00:00.0330033
    Line 1080: 085830.509   7   4   3       OnCompletion_ktTel_MakeCall sRet=[<result>ok</result><crn>536870915</crn><crnx>20000003</crnx>] sCidSentThisCall=[]
    Line 1081: 085830.509   7   4   3       set crn_CurrentMakeCallAttempt to: 20000003
    Line 1082: 085830.510   7   4   3 state Dialing (auto) 9(614)9406824 .
    Line 1083: 085830.511   7   4   3       L1_set Dialing (iState=LS_WAITAFTERDIALINGOUT)
    Line 1095: 085831.039  25   4   3 ev    Dialogic 135,TDX_SETHOOK, crn=20000003, 0,0,0,DX_OFFHOOK,CALL_OUTBOUND,
    Line 1096: 085831.039  25   4   3       q_scr +     evScriptEvent 135 TDX_SETHOOK
    Line 1110: 085831.042   7   4   3       q_scr run   evScriptEvent sCode=[TDX_SETHOOK] iActionID=0, crn=20000003 [0|0|0|0|0][DX_OFFHOOK|CALL_OUTBOUND||||] 00:00:00.0030003 max:6|00:00:00.0330033
    Line 1111: 085831.042   7   4   3       se    TDX_SETHOOK 135  0|0|0  DX_OFFHOOK|CALL_OUTBOUND| LineState=LS_WAITAFTERDIALINGOUT
    Line 1112: 085831.042   7   4   3       LsWaitAfterDialingOut : 135,20000003,TDX_SETHOOK,0,0,0,DX_OFFHOOK,CALL_OUTBOUND,
    Line 1220: 085847.669  25   4   3 ev    CallState TDX_CALLP_CR_CNCT, crn=20000003, iEvent=0 ,256,2,4, s1:, s2:, s3:]. build_date: 20-Jun-15 22:15:24.09
    Line 1221: 085847.669  25   4   3       q_scr +     evCallState 0 TDX_CALLP_CR_CNCT
    Line 1222: 085847.669  25   4   3 ev    Dialogic 133,TDX_CALLP, crn=20000003, 10,3,0,CR_CNCT,CON_PVD,
    Line 1223: 085847.669   7   4   3       q_scr run   evCallState sCode=[TDX_CALLP_CR_CNCT] iActionID=0, crn=20000003 [256|2|4|0|0][|||||] 00:00:00 max:6|00:00:00.0330033
    Line 1224: 085847.669  25   4   3       q_scr +     evScriptEvent 133 CON_PVD
    Line 1225: 085847.670  25   4   3       q_scr +     evScriptEvent 133 TDX_CALLP
    Line 1226: 085847.670  25   4   3 ev    Dialogic 134,TDX_CST, crn=20000003, 10013,0,0,DE_LCON,,


#3 bpolack 01 August 2015 - 06:19 AM

Thanks you for the response.

We performed the test you suggested, (swapping lines in the bad port with one that was working) and the port that was working now fails, while the other (bad) port now works.

 

Our line problem is not intermittent.  It always occurs on that phone line.

 

We changed the physical phone cord and re-tested making an out-going call, but got the same result.

 

Anything further we can try?



#4 SupportTeam 01 August 2015 - 07:29 AM

That would suggest that the issue lies with the device/PBX from where those lines originate.

 

Or, if the "physical phone cord" was not plugged directly into that device/PBX, then problem may lie with the wiring between that device/PBX and the wall socket to where the "physical phone cord" was attached.