Jump to content


andrewfleury

Member Since 08 Jul 2008
Offline Last Active May 24 2017 04:54 AM

Posts I've Made

In Topic: Run Program Fails

24 May 2017 - 12:25 AM

100704.267   8   2   2 state [Run Program 47] Run Program
100704.271   8   2   2       File.Exists(C:\Program Files (x86)\RealPopup\RealPopup.exe) is true
100704.271   8   2   2       running program=[C:\Program Files (x86)\RealPopup\RealPopup.exe], arguments=[-send -noactivate "computername" "test from vg"], RunWait=0
100704.272   8   2   2       ShellExe start [C:\Program Files (x86)\RealPopup\RealPopup.exe][-send -noactivate "computername" "test from vg"] UseShellExecute=0
100704.274   8   2   2       WindowStyle set to ProcessWindowStyle.Hidden
100704.277   8   2   2       start non-UI process failed. Trying to start process as logged in user. (requires an active user login session on system)
100704.285   8   2   2       start user process: hProcess=1148, dwProcessId=732, hThread=12732, dwThreadId=2768
100704.285   8   2   2       RunModule finish

After installing the supplied version above

In Topic: Problem With Vbscript

17 May 2017 - 05:06 AM

Hello,

A continuation of this thread from 2015

We had previously set up the server to reboot on a daily basis and that helped for a while. But now it started to get worse
We Contacted Voiceguide a while back and were told the version 7.4 was no longer available to us (a free upgrade) and that we had to buy version 7.5.

This is what we did, and the problem persists and is actually now worse and happening more often

Here is a normal call that works:

142428.098  26   6   4       not saving script (strIni_moduleRunScript_SaveToFile not set)
142428.098  26   6   4       runscr waiting. wait=1, calling iModuleIdx=27 (setting iRunWait_VgmIdx to 27)
142428.098  26   6   4       moh file not specified
142428.098  26   6   4       runscr call ClearScript Execute
142428.098  26   6   4       runscr new VBScriptEngine call
142428.098  26   6   4       runscr .Execute call



And when it starts Failing:

130620.452  33   6   4       not saving script (strIni_moduleRunScript_SaveToFile not set)
130620.452  33   6   4       runscr waiting. wait=1, calling iModuleIdx=27 (setting iRunWait_VgmIdx to 27)
130620.452  33   6   4       moh file not specified
130620.452  33   6   4       runscr call ClearScript Execute
130620.452  33   6   4       runscr new VBScriptEngine call
130620.452  33   6   4 ERROR v7.5.6267.23382 (27-Feb-17 12:59:25.18) Run_VBS_main_catchall : The system cannot find the file specified
 
   at MS.Win32.UnsafeNativeMethods.RegisterClassEx(WNDCLASSEX_D wc_d)
   at MS.Win32.HwndWrapper..ctor(Int32 classStyle, Int32 style, Int32 exStyle, Int32 x, Int32 y, Int32 width, Int32 height, String name, IntPtr parent, HwndWrapperHook[] hooks)
   at System.Windows.Threading.Dispatcher..ctor()
   at System.Windows.Threading.Dispatcher.get_CurrentDispatcher()
   at Microsoft.ClearScript.Windows.WindowsScriptEngine..ctor(String progID, String name, WindowsScriptEngineFlags flags)
   at Microsoft.ClearScript.Windows.VBScriptEngine..ctor(String progID, String name, WindowsScriptEngineFlags flags)
   at Microsoft.ClearScript.Windows.VBScriptEngine..ctor(String name, WindowsScriptEngineFlags flags)
   at ..(Object oParam)
130635.280  22   6   4 timer EV_TIMEOUT_GOTOMODULE


I'm not sure where to go from here


In Topic: Errors After Updating Oto 7.5

14 March 2017 - 11:35 PM

Actually strangely enough, all the old files were in a folder called Config while the new ones were in a folder called conf

I did as you suggested and re-used the default config file coming with the installation and added my scripts to it. This stopped the errors.

Thanks