Jump to content


leopard

Member Since 23 Nov 2017
Offline Last Active Nov 30 2017 06:26 AM

Topics I've Started

Only One Line Appears In Vg Monitor

30 November 2017 - 05:50 AM

I have 8 channels of HMP on my system

Attached File  HMP.PNG   1.95KB   2 downloads

 

but only one appears in the voiceguide line status monitor.

Attached File  Monitor.PNG   16.99KB   2 downloads

 

How do I tell voiceguide to use all 8 channels?

 

Config.xml is like this:

<?xml version="1.0"?>

<VoiceGuideConfig>
<Devices_Dialogic>

<Channels>

<Channel>
<Name>dxxxB1C1</Name>
<NetworkIf>iptB1T1</NetworkIf>
<Device_Media>ipmB1C1</Device_Media>
<Protocol>IP</Protocol>
<Script>C:\Program Files\VoiceGuide\Scripts\Credit Card Payment\Credit Card Payment.vgs</Script>
<AllowDialOut>0</AllowDialOut>
</Channel>

<Channel>
<Name>dxxxB1C2</Name>
<NetworkIf>iptB1T2</NetworkIf>
<Device_Media>ipmB1C2</Device_Media>
<Protocol>IP</Protocol>
<Script>C:\Program Files\VoiceGuide\Scripts\Credit Card Payment\Credit Card Payment.vgs</Script>
<AllowDialOut>0</AllowDialOut>
</Channel>

<Channel>
<Name>dxxxB1C3</Name>
<NetworkIf>iptB1T3</NetworkIf>
<Device_Media>ipmB1C3</Device_Media>
<Protocol>IP</Protocol>
<Script>C:\Program Files\VoiceGuide\Scripts\Credit Card Payment\Credit Card Payment.vgs</Script>
<AllowDialOut>0</AllowDialOut>
</Channel>

<Channel>
<Name>dxxxB1C4</Name>
<NetworkIf>iptB1T4</NetworkIf>
<Device_Media>ipmB1C4</Device_Media>
<Protocol>IP</Protocol>
<Script>C:\Program Files\VoiceGuide\Scripts\Credit Card Payment\Credit Card Payment.vgs</Script>
<AllowDialOut>0</AllowDialOut>
</Channel>

<Channel>
<Name>dxxxB1C5</Name>
<NetworkIf>iptB1T5</NetworkIf>
<Device_Media>ipmB1C5</Device_Media>
<Protocol>IP</Protocol>
<Script>C:\Program Files\VoiceGuide\Scripts\Credit Card Payment\Credit Card Payment.vgs</Script>
<AllowDialOut>0</AllowDialOut>
</Channel>

<Channel>
<Name>dxxxB1C6</Name>
<NetworkIf>iptB1T6</NetworkIf>
<Device_Media>ipmB1C6</Device_Media>
<Protocol>IP</Protocol>
<Script>C:\Program Files\VoiceGuide\Scripts\Credit Card Payment\Credit Card Payment.vgs</Script>
<AllowDialOut>0</AllowDialOut>
</Channel>

<Channel>
<Name>dxxxB1C7</Name>
<NetworkIf>iptB1T7</NetworkIf>
<Device_Media>ipmB1C7</Device_Media>
<Protocol>IP</Protocol>
<Script>C:\Program Files\VoiceGuide\Scripts\Credit Card Payment\Credit Card Payment.vgs</Script>
<AllowDialOut>0</AllowDialOut>
</Channel>

<Channel>
<Name>dxxxB1C8</Name>
<NetworkIf>iptB1T8</NetworkIf>
<Device_Media>ipmB1C8</Device_Media>
<Protocol>IP</Protocol>
<Script>C:\Program Files\VoiceGuide\Scripts\Credit Card Payment\Credit Card Payment.vgs</Script>
<AllowDialOut>0</AllowDialOut>
</Channel>


</Channels>

</Devices_Dialogic>



<VoIP_Lines>


</VoIP_Lines>




</VoiceGuideConfig>


Sip Registration Not Working

23 November 2017 - 06:25 AM

Using HMP on windows 10 Pro 32-bit.

 

Dialogic service and voiceguide service are started successfully.

 

But I am unable to receive calls and my SIP provider says they do not see my registration appearing on their end.

 

What am I doing wrong?

 

Below are the changes I made to config.xml. 

<VoIP_Registrations>

<VoIP_Registration>
<Display>Test</Display>
<Protocol>SIP</Protocol>
<RegServer>sip2.jivetel.com</RegServer>
<RegClient>ciscotest@sip2.jivetel.com</RegClient>
<LocalAlias></LocalAlias>
<Expires>60</Expires>
</VoIP_Registration>

</VoIP_Registrations>

<VoIP_Authentications>

<VoIP_Authentication>
<Display>Test</Display>
<Realm></Realm>
<Identity></Identity>
<AuthUsername>ciscotest</AuthUsername>
<AuthPassword>d97ftda6-637c-9aa2-b</AuthPassword>
</VoIP_Authentication>

</VoIP_Authentications>